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1 Introduction

This document will walk you through setting up Stratusphere Fit, the Assessment solution from Liquidware
Labs. This is not a complete training or user guide, but is meant to guide you through the basic steps to setup
the product and to introduce you to key features, reports and capabilities, so that you can determine whether
Stratusphere is suitable for your assessment needs. It is assumed you will use the evaluation license that comes
with the free version of Stratusphere, allowing you to run the product for 10 days, and to assess up to 5 users &
5 desktops.

1.1 Topics Covered

During the course of this guide, you will:

Learn how to install and configure the Stratusphere Hub virtual appliance

Learn how to deploy Stratusphere Connector ID Keys to gather assessment data

Learn the key components of the Stratusphere assessment product module

Learn how to review environment inventory and configuration for desktops, applications
Learn how to review resource consumption data for desktops, users and applications
Learn how to generate assessment findings and results

<K<K K<L

1.2 Target Audience

This document is meant for consultants and customers who are considering desktop virtualization, and who may
have use of an assessment tool to help with desktop virtualization planning. Technical skills required are
minimal, however some familiarity with adding virtual machines on VMware or XenServer and deploying
software to user desktops is expected.
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2 Assessment Prep 1: Install and Configure Stratusphere™

This section describes the steps to setup and complete data gathering on a target set of user desktops.

The Stratusphere Hub is a virtual appliance that you can install directly from the Liquidware Labs web site. It
contains everything you need to conduct and complete a virtual desktop assessment. The first step is to install
the virtual appliance on your virtual host. The virtual appliance requires 1 gigabyte of memory and 4 gigabytes
of disk space (for larger product assessments you may choose to expand memory up to 16 gigabytes of memory
and may require larger disk space to keep all data). The Hub includes the feature to monitor network latency
from user desktops to the Hub. In an assessment, if you place the Hub in the datacenter where virtual desktops
may reside in the future, you can use this feature to measure the latency between end user locations and the
datacenter.

The following sections describe how to configure the virtual switch and install the Stratusphere Hub virtual
appliance on either VMware vSphere or Citrix XenServer, and subsequent installation and configuration steps.

2.1 Install the Stratusphere Hub Virtual Appliance (VMware vSphere)

The Stratusphere Hub virtual appliance can be downloaded directly from Liquidware Labs web site onto your
VMware host. To do this, open the VMware vSphere Client and connect to your target VMware vCenter host.
In the vSphere Client, select File > Deploy OVF Template... and provide the URL for the Stratusphere virtual
appliance (OVF) that is listed on the Liquidware Labs product download page. Complete the appliance install
wizard by accepting the evaluation license terms, providing the name, selecting the host, data store, and network
port. The virtual appliance will then automatically be downloaded and installed.

i (%)) Deploy OVF Template |.E|E‘£—hj1

Source
Select the source location.

" Deploy from file:

F:\Lwl OVF\stratusphere_hub-daily.ovf J

Choose this option if the source OVF template (*.ovf) is on the local file system.
For example, your C: drive, a network share, or a C0y/DVD drive.

{*+ Deploy from URL:

|htt|:|:ffsu:nf'tware.quuidwarelabs.cDmH. 7.0 stratusphere_hub.owf ﬂ

Choose this option to download the OVF template from the Internet and enter a
URL such as hitp://www.example. com/template. ovf

Help | < Back | Mext = I Cancel |
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2.2 Install the Stratusphere Hub Virtual Appliance (Citrix XenServer)

To install on XenServer, download and install the virtual appliance onto your host. To do this, you will first
need to download the XVA .zip file from the Liquidware Labs web site and un-zip the XVVA. Next, open the
XenCenter Client and connect to your target XenServer host. In the XenCenter Client, select File > Import VM
and proceed through the wizard, specifying the location of the downloaded XVA file. The virtual appliance is
now ready; you can start it and move to the next step.

File | View Pool  Server WM Skc

| Irnpork WM.,

B Impart Search. ..

Exit

é labx=01
=1 DVD drives
= Local storage

S I T

X [mport

@g Complete the import e

Import source

Click the Finish button to complete the impart process and close the wizard,
Home server

Storage The import process may take several minukes,

Metwork

Automatically start new Y

To have wour new Y¥M stark up as soon as the import process is complete seleck this checkboo,

i
CiTRIX
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2.3 Install the Stratusphere Hub Virtual Appliance (Microsoft Hyper-V)

To install on Microsoft Hyper-V, download and install the virtual appliance onto your host. To do this, you will
first need to download the .zip file from the Liquidware Labs web site and un-zip it.

p anag _ |0 X
g; File Action VYiew ‘Window Help |;|i|ﬂ
= (*mHE
Actions
ouan ;
Tew » WIN-42WO00DIESE3P -
X . State CPL Uzage Lptime Operations
Import Yirtual Machine. .. o Mew 3
Hypet-4 Sethings. .. imial Running 0% 1214:56:32 | = Import Yirtual Machine. ..
Wirkual Network Manager. .. e-hub Running 0% 4.00:33:00 - )
[*=) Hyper-¥ Settings...
il Bt % wirtual Metwork Manager. ..
Inspeck Disk, ..
24 Edit Disk. ..
Stop Service
Remove Server ng Inspect Disk...
Refresh @ Stop Service
Wigw 3 | % Remaove Server
Mew Window from Here L
(@ Refresh
Help d View »
The zelected virtual machine haz no snapshots. Mew Window from Here
E Help
stratusphere-hub -
E;é Connect. ..
2 Settings...
@ Turn OFF..
@ shut Down...
@ Save
Il Pause
UD Reset
Created: 7/21/2011 5:01:55 PM Heartbeat: Mo Contact S Snapshot
Notes:  Mone Memory Usage: 1024 MB =] Rename
E Help
| 3|
|Disp|ays the import existing virtual machine user interface, | |

Next, open the Microsoft Hyper-V Manager Client and connect to your target Hyper-V host. Right-click on the
Hyper-V host and select the “Import Virtual Machine...” menu option.

Import ¥irtual Machine | x| |

Import Path || Browse |

™ Reuse old vitual machine [Ds.

[ rpmrt I Cancel |

After import, the files under thiz import folder will be used by the imported
wirtual machine. Thiz falder cannot be imparted again.

Select the folder that contains the files that were extracted from the zip file above by clicking on the “Browse”
button above.
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Settings for hub481 M= e

|92 Hardware [l Add Hardware

‘fou can use this setting to add devices to wour virtual machine,

A BIOS

Bioot from 0 Select the devices you want ko add and click the Add button,
il ermory

1024 ME Metwork, Adapker
D Processor Legacy Metwork Adapter

1 Virtual processar
= i IDE Contrallzr 0
i Hard Drive

hub4a1_1.vhd
—w Hard Drive

hub4a1_2.vhd
= B IDE cantroller 1 You can attach virtual hard disks to & SC3T controller bo increase the amount of storage
) available to a wirtual machine. Install the inkegration services in the guest operating
1% DV Drive system ko improve performance when using storage attached ko a SCSI controller, Do
Mane nok attach a swskem disk ko a SCSI controller, & virtual hard disk that contains an
0 Legacy Metwork Adapter operating syskem must be attached o an IDE controller,
W Mebwork,
= com
Mane
= comz
Mone
[ Diskstte Drive
Mone
# Management
| Mame
hub4a1
_“'_. Integration Services
All services offered

add

1| Snapshot File Location
Ci\UserstAdministratorDocuments, .
-:j Aukomatic Start Action
Restart if previoushy running
-:j Automatic Stop Action
Save

Ok, I Cancel | Apply |

Once imported, select the Settings link for the imported virtual machine. You can choose to update the amount
of Memory and Processors associated with the Stratusphere™ Hub. You can also add an additional disk to an
available hard disk controller. Please make sure the Network Adaptor is connected to a valid VM Network with
the right VLAN ID tags. The virtual appliance is now ready; you can start it and move to the next step.

2.4 Configure Stratusphere™ Hub

On completion of the import into the virtual host, you can edit settings on the Hub to set the CPU/Memory
settings. You can add an additional hard disk with the required amount of space based on the
“LiquidwareLabs.Stratusphere.DatabaseDiskSizing” guide. Instructions to add the disk to the appliance are
available at LiquidwarelLabs.com. Now you can power ON the virtual appliance. You can open a console to the
virtual appliance and watch the boot sequence. The Hub can now be configured using the Web Ul as well as the

Hub console.

2.4.1 Configure Stratuspher e E. Hub wusing Web Ul

If DHCP is enabled on the local network subnet, the Stratusphere™ Hub will acquire a DHCP network address.
On completion of the boot sequence, the appliance will provide information on how to connect to the Web
based Administration interface of the virtual appliance. As shown in the image below, it will display the URL
that can be used to connect to the Stratusphere™ Hub along with the default administrative credentials.

© 2010 Liquidware Labs Page 6




sers (authorized or unauthorized) have no explicit or implicit
expectation of privacy.

ny or all wuses of this system and all files on this system may be
intercepted, monitored, recorded, copied, audited, inspected, and
isclosed to your employer, to authorized site, government, and law
enforcement perszonnel, as well as authorized officials of government
genciesz, both domestic and foreign.

By using this system, the user consents to such interception, monitoring,
recording, copying, auditing, inspection, and disclosure at the
iscretion of such personnel or officials. Unawuthorized or improper use

of this system may result in civil and criminal penalties and
dministrative or disciplinary action, as appropriate. By continuing to
1se this system you indicate your awareness of and consent to these terms
nd conditions of uwuse. LOG OFF IMMEDIATELY if you do not agree to the

onditions stated in this warning.
3o 3ok Jb- oE- 3o - o E BE JoE -3 JoE-JoE b b BoE JoE o JoE BE BE b o oE-E-BE b B JeEJoE Jeb b -E o oEBE -BE B3 JeE-JeE b b BoE 3eE o oE BE E oo oE -E-BE b B JeE JoE Jeb b -E o E-E E BE BE-BEJE-E BEE-BEBE

localhost login:

You can now open your browser and navigate to the URL as shown in the console above. You can log into the
Administration module using the default user id and password as shown above.
File Edit View History Bookmarks Teels Help *ﬁi;aioé‘ iiiia https://10.0.80.101/vscenter/app/login - =

9. LogIn | Liquidware Labs x

Q: Liquidware

Log In
Product Administration - Licensed Products:
Domain Local Directory ~ Stratusphere Fit — Assessment and capacity planning
=T ems Stratusphere UX — Diagnostics and service leve! assurance
ProfileUnity — User profile migration and management
Password

Licensed To: Evaluation License
Logln License Expires: Nov 22, 2010
Desktop Limit: 0 used out of 5
User Limit: 0 used out of 5

© 2010 Liguidware Labs, Inc.
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On successfully logging in, you will need to accept the End User License Agreement (EULA).

€ LiquidwareLal

License

LIQUIDWARE LABS, INC.
EVALUATION LICENSE V.2009-06
1. SCOPE OF RIGHTS.

1.1. License Grant. Liquidware Labs, Inc. ('Liquidware') grants to you ('Company') a nonexclusive, nontransferable, nonassignable, time limited license to use the
downloaded software (the 'Software") on one (1) computer for a limited period from the date of download (the 'Evaluation Period") solely for Company's (i)
internal evaluation of the Software and (ii) Company's use in your professional services engagements, without the right to further sublicense, distribute, transfer
or transmit the Software. All licenses granted are for use of the Software in object code format only, and under no circumstances will Company be entitled to
source code.

1.2. Restrictions. Except as expressly permitted in this Agreement, no express or implied license or right of any kind is granted to Company and Company shall

not (i) make any additional copies of the Software; (i) reverse assemble, decompile, or otherwise translate, or use, copy, modify, or distribute the Software by
any means; (iii) remove any copies of the Software from the site or equipment designated; or (iv) charge, or allow others to charge, any third party for use of

the Software. Company acknowledges that the Software contains keys that may limit or terminate its use.

2. NO SUPPORT. Company acknowledges that it is not eligible to receive Software support or bug fixes unless purchased separately from Liquidware.

3. TERMINATION. This Agreement and the right to use the Software will continue until the expiration of the Evaluation Period or until terminated by Liquidware.
Liquidware may terminate this Agreement for any reason upon notice to Company. Upon the expiration or termination of this Agreement, all rights and licenses
granted to Company hereunder shall terminate immediately and Company shall (i) cease all use of the Software; and (ii) delete all copies of the Software under
Company's control. Upon Liquidware's request, Company shall alse provide Liquidware with a signed written statement certifying that it has returned all
Liquidware property to Liquidware. Upon termination of this Agreement, the provisions of this Agreement concerning the ongoing interests of the parties shall
continue and survive in full force and effect.

4, DISCLAIMER OF WARRANTY. Company acknowledges and agrees that the Seftware is provided 'AS IS'. LIQUIDWARE DOES NOT MAKE ANY EXPRESS OR

| | Agree |) Mo Thanks |

Then enter all the required registration information. You can choose to “Generate a New License” or choose “
have a product license key” to paste in the license you may have received from Liquidware Labs.

@ LiquidwareLak

License

Thank you for downloading and installing the Liquidware Labs virtual appliance. This virtual appliance includes:

* Stratusphere Fit — for assessment and capacity planning
» Stratusphere UX — for diagnostics and service level assurance
+ ProfileUnity and ProfileUnity Pro — for user profile migration, management, and deployment integrity

Please enter your company information and license below to get started.

Registration Information

Please complete the information below to obtain techical support. Note that this information will be sent to Liquidware Labs

* Your name:  Jghn Doe

* Your email: John.Doe@mycorp.com
* Your phone number: (555) 555-1212
* Your company: My Corp
* Company installed at: My Corp

= . . .
License: @ Generate an evaluation license
I have a product license key

This evaluation license will allow you to evaluate all product capabilities for 15 days, on up
to 5 desktops. To receive a production license, or to request an extended evaluation, please

contact Liguidware Labs.

¥| 1 have read and accepted the terms of the applicable Liquidware Labs, Inc. license: Evaluation Software License, End User Software License, Fartner Agreement.

/\
(| Get Started |D Mo Thanks
~—
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Once you click on “Get Started” you will be presented with a page to configure the virtual appliance.

% LiquidwareLabs

* The appliance is currently on a DHCP address. You must assign a static IP address before using the other features.
® Also, set a DNS name that corresponds to the static IP address for use by Connector ID Keys.
* We recommend turning on NTP and setting your preferred NTP Server(s)

Appliance Network Configuration

* Host Mame: hub01.mycorp.com * DNS Name: hub01.mycorp.com
Necessary for CIDs to send inspection reports

* 1P Address: 10.0.30.50 DNS Server Addresses: 10.0.10.12,10.0.10.13
Use static IP address Comma-separated
* Metwork Mask: 2552552540 DNS Search Suffixes: prod.mycorp.com, mycorp.com
Comma-separated
* Default Gateway: 10.0.80.1 Time Zone US/Eastern -
Enable NTP: [V Time Servers tick.mycorp.com, tock.mycorp.com

Comma-separated

P e ———
:Save Changes:

Here is a brief description on the fields on this page:

1. Host Name: Please enter a hostname for the appliance. It can be a short name or a fully qualified host

name.

2. IP Address: Provide a static IP Address for the virtual appliance. Since the appliance booted up using
DHCP it will potentially need to give up the same address unless it's reserved within the DHCP server. It
is strongly recommended to change it to a Statically allocated IP Address.

Network Mask

Default Gateway

DNS Name: IMPORTANT: Please enter the fully qualified DNS entry name associated with this static

IP Address. The CID Keys will call back to the Stratusphere™ Hub based on what is in this field. It is

strongly recommended that you use a DNS Entry name here instead of IP Address so as to circumvent

any future issues that may crop up due to reconfiguring the IP Address of the appliance.

6. DNS Server Addresses: Please enter 1 or more IP Addresses of your DNS server in a comma separated

list.

DNS Search Suffix: Please enter the local DNS search suffixes available within your local network.

Time Zone: Please select your local time zone from the drop down list.

9. Enable NTP: Please enable this option to avoid time drift and keep the Stratusphere™ Hub’s time
synched and accurate.

10. Time Servers: This field comes pre-populated with some public time servers. You can choose to enter
your own comma separated list of time servers as well. These can be entered as IP Addresses and/or

DNS entry names.

Cancel and Logout |

oA~ w

o~

On “Save Changes” all these configuration fields will be saved and if you have configured the new Static IP
Address correctly, the browser will redirect you to your new IP Address based URL. This initial Appliance
Network Configuration page is only available on first run and will not be available subsequently.

In addition to using the browser based interface, the Stratusphere™ Hub virtual appliance can also be
configured through the console.
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242 Configure StratusphereE Hub using the Consol e

If DHCP is not available on the local subnet, then you can use the Console to configure the Stratusphere™ Hub.
Open up the console to the Stratusphere™ Hub on VMware VI Client and vSphere Client as well as the
XenCenter or XenServer. Once opened, use the following default credentials to log in:

User ID: ssconsole
Password: sspassword

Here is a list of commands to configure the appliance:

set management ip <static.ip.address>

set management netmask <network.mask>

set management default gateway ip <default.gateway.ip.address>

set dns server < dns. ip.address.1>[,< dns.i p. address. 2>, é] ]

set dns search <dns.suffix.1>[,<dns.suffix.2>,],
write

set system hostname <hostname>

set system hub dns name <hub.dns.or.ip>

set system mail relay server <mail.relay.ip.dns>

set system timezone <Continent/City>

set system time <yyyymmddhhmm>

set ntp server <time l. server.ip.dns>[,<time2.server.ip.dr
set ssh ssconsole on

set ssh on

write

set ntp on

write

exit

These commands are used to configure or re-configure the appliance if it needs to change its IP Address or a
new time server etc. Make sure you execute the “write  ”” command before exiting the console as that actually
saves the changes made so far.

2.5 Stratusphere™ Database Appliance

The Stratusphere™ Database Appliance is used when more than 1,000 CID Keys report back to the
Stratusphere™ Hub using the default callback frequency of 60min. Liquidware Labs recommends using the
database from the Stratusphere™ Hub 4.8.x to create the database on the Stratusphere™ Database Appliance.
NOTE: Pleaseupgrasl t he StratusphereE Hub to the | atest 4
Database Appliance

The process begins with importing the Stratusphere™ Database Appliance software from Liquidware Labs
Download site. Once imported, configure the Database Appliance as a statically addressed virtual appliance.
The user must then copy a script to the Stratusphere™ Hub. This script prepares the Stratusphere™ Hub for an
external database. It exports the database into a backup file and shuts down the database service on the
Stratusphere™ Hub. It then transfers this file to the Stratusphere™ Database Appliance. On the Stratusphere™
Database Appliance, run a similar script to accept and restore the database backup file, enable services, and
configure communication services between the Stratusphere™ Hub and Database Appliances. Once configured,
the two appliances can communicate with each other and are now configured for enhanced performance and
scalability. For detailed instructions please refer to the “LwL.Stratusphere.InstallingDatabaseAppliance.pdf”
document.
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251 Installing Stratuspher /HwabeavSphdrggse Appl i ance
The Stratusphere™ Database Appliance can be imported using VMware vSphere Client directly from
Liquidware Labs web site. To do this, open the VMware vSphere Client and connect to your target VMware
vCenter host. In the vSphere Client, select File > Deploy OVF Template... and provide the URL for the
Stratusphere Database virtual appliance (OVF) that is listed on the Liquidware Labs product download page.
Complete the appliance install wizard by accepting the evaluation license terms, providing the name, selecting
the host, data store, and network port. The virtual appliance will then automatically be downloaded and
installed.

f (%) Deploy OVF Template o | E S

-

Source
Select the source location.

Deploy from a file or URL

Browse, .,

Enter & URL to download and install the OVF package from the Internet, or
specify a location accessible from your computer, such as a local hard drive, a
netwark share, or a CO/DVD drive.

Help | < Back | Mext = I Cancel

A

e

252 Configure StratusphereE Database Appliance

Liquidware Labs recommends hosting the Stratusphere™ Database Appliance on the same virtual host, same
virtual switch, and same port group as the Stratusphere™ Hub Appliance. This configuration will ensure fastest
communication response time between the Hub and the Database for high performance and scalability. Please
ensure that there are significant CPU/Memory/10 resources available on the host as these are major server class
virtual machines. After downloading the Stratusphere™ Database Appliance, please assign 2 vCPUs, 8GB of
Memory, set the required amount of disk space on the second disk (default is 30GB), and connect the NIC to the
same virtual network switch and port group as the Stratusphere™ Hub. Then power ON the appliance and go to
the console of the virtual machine to start the configuration of the appliance. The database appliance includes a
wizard for configuring the database that will prompt for required information. If you wish to use the default
value for any setting you may do so by pressing the Enter key to move directly to the next setting. The wizard
will ask for:

1. Current Value of Hostname:

2. Do you want to use DHCP (Y/N)? If you choose No, it will prompt for static IP Address. Liquidware

Labs recommends using static IP Addresses.
3. What Address IP do you want to use?
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What Netmask do you want to use?

What is the default gateway?

What Primary DNS server do you want to use?
What Secondary DNS Server do you want to use?
What Tertiary DNS Server do you want to use?
Enable the NTP Time Server Service [Yes]?

10 What NTP Time Server do you want to use?

©OoN A

This is an example of a completed configuration. Please note that names and IP addresses will vary according
to your environment.

@dh_l]?l 1 on esx5.trustednetwork.biz == B3
Fil= View WM
E 0|y B8 603 S

Do you want to save this configuration (WritesEditrsAbort- fuitsNors#t) 7 _

To release cursor, press CTRL + ALT

Save your configuration using the “write” command. You will finish with a screen showing the status of your
database.

@db_ﬂ?l 1 on esx5.trustednetwork.biz 1 [=] S
File Wiew WM
mip @8 @ B &

localhost.localdomain
(pid 3844) is running...

5:28 up 22 min, B users, load aueraqe B.86, B.81, B

total,
total,

y IP Address

WY Login to Console JRA Pl This Screen_
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The Stratusphere™ Database Appliance is not configured and ready to receive its database from the
Stratusphere™ Hub.

2.5.3 Transfer Databasefrom St r at us p h etp PafabaseiAppliance using the Console

Log in to the consoles of the Stratusphere™ Hub and Database Appliance using root/sspassword credentials.
Keep these two console windows next to each other as instructions need to be executed on both these appliances
during the transfer.

Switch to Stratusphere™ Database Appliance Console
1. Log in to the console of the Stratusphere™ Database Appliance using root/sspassword.
2. To prepare the Stratusphere™ Hub for transferring its data we need to copy a script over to the Hub. To
do so, execute the following command:

$ scp /opt/lwl/bin/ext.preparehub.sh friend@ <Hub IP. DNS>»/home/friend /

The command will prompt whether to connect, accept keys and ask for a password. Use the
default “sspassword”. This script is now copied to the Stratusphere™ Hub. We need to log into
the Hub and execute it.

Switch to Stratusphere™ Hub Appliance Console
1. Log in to the console of the Stratusphere™ Hub Appliance using root/sspassword.
2. We now need to stop the Stratusphere™ Hub Appliance database services, backup the data to a file and
move it over to the Stratusphere™ Database Appliance. Execute the following command:

$ /home/friend/ext.preparehub.sh

Important: Oncethe files areanoved over, this command withuse omwait for you to execute

the corresponding commaielowby switching consolesn t he Str atusphere
Appliance DO NOT ENuUStgeR fAiyeso

The command will display status messages for stopping services etc. and will then prompt the

user for the IP or DNS of the Stratusphere™ Database Appliance. This command too will

prompt whether to connect, accept keys and ask for a password. Use the default “sspassword”.

The database is now stopped and backed up to a file which has been transferred over to the
Stratusphere™ Database Appliance. The command will then pause until the database is restored

on the Database Appliance below.

Switch to Stratusphere™ Database Appliance Console
1. Execute the following command:

$ [/ opt/lwl/bin/ ext.preparedb.sh

The command will now start restoring the database backup file copied over from the
Stratusphere™ Hub Appliance. If the database is of a large size this may take a significant
amount of time. Once completed, the command will display the following message:

s oA s oA z

I BT OOET ¢ AAOAAAOGAATE
The database transfer and restore procedure is now complete.

Switch to Stratusphere™ Hub Appliance Console
1. The Stratusphere™ Hub console will be waiting for user confirmation if the Stratusphere™ Database
Appliance command finished successfully. Now enter “Yes” to continue.
2. Just in case you entered “Yes” prematurely (i.e. before coming to this step and before completing the
Stratusphere™ Database ext.preparedb.sh ~ command), please log into the console of the
Stratusphere™ Hub Appliance using ssconsole/sspassword and execute “restart services” command.
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254 Complete StratusphereE Database Appliance configurati ol

Once the procedure is complete please verify the integrity by logging into the Stratusphere™ Web Ul Log in to
the Administration section using ssadmin/sspassword credentials. Navigate to the Hub Administration > Data
Retention > Status tab and verify the free space available based on the configured space of the Stratusphere™
Database Appliance. The database transfer and restore procedure is now complete. If you see any other
messages or errors please contact Support@LiquidwarelLabs.com.

2.6 [Optional] Setup User Groups and Machine Groups

Now that you are logged into the Administration module, the first thing to consider is whether you will be
defining any user groups or machine groups for your assessment. You may choose to setup groups if you have
distinct sets of users or desktops that you want to analyze separately during the assessment. These groups do
not need to be setup prior to the assessment, however if you set them up prior you can immediately use the
groups as you proceed through later steps. Groups can be useful for production assessments especially in larger
environments, but are optional for this evaluation.

Machine groups can be used to group desktops for assessment, for example by location or by department. To
define machine groups, go to Inventory > Machines, select Groups, and then click the New button.

i - -
& LiquidwareLabs pomt | 1o | Log out
Hub Administration Station Administration Event Log Licensing Configuration
| Machines | Users Applications Subnets
Machines Page 1 of 1 = Prev Next =
View: Individual Machines [ Groups
[l Name A Type 05 Version CK:;",_‘,"“?’:D Created On Last Contact
Showing 1 - 1 of 1 [¥] Page 1 of 1 [¥] < Prev Mext >

Version: 4.7.0 Evaluation License for up to 5 desktops unti Mov 22, 2010 © 2010 Liguidware Labs, Inc
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€ LiquidwareLabs bt i | Loa ot

Hub Administration Station Administration Event Log Licensing Configuration

| Machines | Users Applications Subnets

Machine Groups Page 1 of 1 < Prev Next >
View: Individual Machines | Groups

I Group Name A Description Count VM Directory Created On

& AD/LDAP Servers 0 members Mov 12, 2010 5:24:28 PM EST

[ CID Key Desktops 0 members Mov 12, 2010 5:24:28 PM EST

[ DHCP Servers 0 members Mov 12, 2010 5:24:28 PM EST

A DNS Servers 0 members Mov 12, 2010 5:24:28 PM EST

| Ermail Servers 0 members Mov 12, 2010 5:24:28 PM EST

[ Fila Servers 0 members Mov 12, 2010 5:24:28 PM EST

| FTP Servers 0 members Mov 12, 2010 3:24:28 PM EST

| MS SQL Servers 0 members Mov 12, 2010 5:24:28 PM EST

[ MNTP Servers 0 members Mov 12, 2010 5:24:28 PM EST

[ Stratusphere Network Stations 0 members Mov 12, 2010 5:24:28 PM EST

& Web Servers 0 members Mov 12, 2010 5:24:28 PM EST

Showing 1 - 11 of 11 [¥] Page 1 of 1 [ < Prev Mext =

Version: 4.7.0 Ewvaluation License for up to 5 desktops until Nov 22, 2010 © 2010 Liguidware Labs, Inc

& LiquidwareLabs Pt e | Lo out

Hub Administration Station Administration Event Log Licensing Configuration

| Machines | Users Applications Subnets

Create Machine Group

Group Properties

*Name: MNew Machine Group

Description! The first machine group or department or location]

(’ Create Machine Group n Cancel
rl

Version: 4.7.0 Ewvaluation License for up to 5 desktops until Nov 22, 2010 © 2010 Liguidware Labs, Inc

User groups can be similarly created by hand by going to Inventory > Users, selecting Groups, and then clicking
on the New button. With user groups you also have the choice to import groups from your Active Directory or
LDAP, or from a file. IMPORTANT: Importing User and Group information from Microsoft Active Directory
is irreversible i.e. once imported the Active Directory should not be deleted as it would delete all users as well.
As a best practice, please take a snapshot of Stratusphere™ virtual appliance prior to importing any data from
Active Directory. For this assessment, if you want to setup user groups either create them manually, or import
from a file by going to Hub Administration > User Directories, and select Import From CSV File from under the
Local Directory. Information on the file formats for user groups and users can be found there.

IMPORTANT: Importing User and Group information from Microsoft Active Directory is irreversible i.e.
once imported the Active Directory should not be deleted as it would delete all users as well. As a best practice,
please take a snapshot of Stratusphere™ virtual appliance prior to importing any data from Active Directory.
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@ LiquidwareLabs
l Hub Administration Station Administration Inventory Event Log Licensing Configuration
Data Retention Connector ID Keys ProfileUnity Agents VM Directories | User Directories | Backup & Restore

Directories

MNew Directory | Click the directories below for more options.

¥ Local Directory (Policy Center)
Status Auto-Registration Impaort From CSV File

Groups file (CSW):

Group file format
Each line of file has the following format:

[group-name],[user-namel;user-namez2;...;user-namen]

Users file (CSV): Browse_

Each line of file has the following format:
[user-name],[role(user or administrator)],[email-address], [active(true or false)],[group-
namel;... ;group-nameM]

Station Policies: [ Update policies on Network Stations after import
Note: Policies will not be updated if the administrator has made any changes since the last
update

Version: 4.7.0 Evaluation License for up to 5 desktops unti Nov 22, 2010 © 2010 Liguidware Labs, Inc

2.7 Review Data Collection Settings

The next step is to review your data collection settings. While logged in to the Administration module, click on
Hub Administration > Connector ID Keys. The first thing you will see is a set of Properties that control the data
collection functions. Some notes on key properties (and suggested defaults are in screen shot below):

- Callback Frequency — the frequency that the Connector ID Key software agents (discussed in next
section) will send collected data back to the Hub; in environments where a single Hub is monitoring
many desktops (more than 500) then you will want to be careful about setting the frequency too low,
since it will increase the network traffic (about 30K to the Hub on each callback) and the load on the
Hub along with the amount of disk space used; note that detailed sizing guidelines and Hub tuning
recommendations can be obtained from Liquidware Labs customer support

- Enable Machine Inspection — indicates that configuration and usage data should be gathered from user
desktops

- Inspection Sample Interval — the frequency at which the Connector ID Key software gathers data on
application and user activity and resource consumption on the user desktop; if the Callback Frequency is
15 minutes or less, then it is recommended that you set the sample interval to 1 or 2 minutes, for longer
callback frequencies it is good to use sample interval of 5 minutes

- Inspect (All the Time, or Only when user logged on) — specifies whether application activity should be
inspected all the time, or only when user logged on if you want to focus strictly on user activity

- File/Folder Size and Counts — specify folders and document types, will cause the Connector ID Keys to
gather data on the number of files and total file size for each folder or file type specified

- Automatically uninstall Connector ID Key software — for Keys that are installed locally on user desktops
(more on install in next section) this setting allows you to specify number of days after which the
software agents on user desktops should “dissolve” (automatically remove themselves). This setting
takes effect as soon as the CID Keys download their settings at the next callback interval. 0 = NEVER.
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- Enable Connector ID for TCP Connections — this allows more accurate tracking of the network latency
between the user desktop and the Hub during the assessment, recommended to leave this on

& LiquidwareLabs print | Help | Log out

[ Hub Administration Station Administration Inventory Event Log Licensing Configuration
Data Retention | Connector ID Keys | ProfileUnity Agents VM Directories User Directories Backup & Restore

Connector ID Key Software Administration
| Connector ID Key Properties | Connector ID Key Software

These properties are used when you create a new machine and are also applied to all existing Connector ID Keys installed on configured machines. Properties are
updated on each Connector ID Key only after it calls back to the Stratusphere Hub. You can set Connector ID Key properties for individual machines in Inventory =
Machines .

Properties

Callback Frequency: 1 hours =

Set how often the Connector ID Key should call back to the Stratusphere Hub. Update interval must be 5 minutes or greater.

Enable Machine Inspection.

Use this option to enable user and application activity inspection with data returned whenever the Connector ID Key calls back
to Stratusphere.

Inspection sample interval : 5 minutes.
The sample interval can be as low as 1 minute however this number should
be lowered cautiously.

Inspect: @ All the time when machine is running.
) Only when user is logged on.

Get size and file count for folders © My Documents, Desktop

Comma separated list of folders. Example: My Documents, M:\UserData,
%USERPROFILE%\Documents, 2%HOMESHAREY.

Get size and file count for file types : esxe, pst, mp3, pdf, txt, doc, docx, ppL,
pptx, xl1s, xlsx

Comma separated list of extensions. Example: doc, doc, ppt
Conduct remote network latency tests :

Optionally enter up to five IP addresses, separated by commas, that will be
used to conduct network performance tests from each machine.

[] Automatically update Connector ID Keys when new software versions are installed in the Stratusphere Hub.

[] Automatically uninstall Connector ID Key software.
Use this option to remove Connector ID Keys after a defined interval from install date.

Properties that only apply to advanced versions

Enable Connector ID for TCP connections.
Use this option to monitor or control TCP connections.

[] Enable Connector ID for UDP connections.
Use this option to monitor or control UDP connections.
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2.8 Distribute Connector ID Keys to Target Desktops

To begin the actual data collection for your assessment, you will need to deploy the Connector ID Key software
to the target desktops. You can find the software by logging in to the Administration module, proceed to Hub
Administration > Connector ID Keys and click on the Software tab. Liquidware Labs recommends using the
Standard CID Key installer that can be used interactively and distributed directly to desktops.

Connector ID Keys are small footprint (less than 3 MB) and run invisibly with minimal performance impact on
the end user desktops. By default when using the Standard version, they will be installed in a folder named
Liquidware Labs\Connector ID in the Program Files folder. The Windows Standard installer has information
that allows it to call back to a Stratusphere™ Hub and register automatically. They communicate securely with
your Hub over TCP and UDP on port 5501.

Note that the “local version” Connector ID Keys can be installed on laptops or other machines that will be used
remote or offline, as long as there are certain times (including initial installation) when the machines are
connected to the network and can reach the IP address (or DNS) of the Stratusphere Hub. Assessment data
collection will continue while the machines are offline, and up to one week of information can be stored locally
until the next time the machine is connected to the network.

& LiquidwareLabs print  Help | Loq out

l Hub Administration Station Administration Inventory Event Log Licensing Configuration
Data Retention Connector ID Keys ProfileUnity Agents VM Directories User Directories Backup & Restore

Connector ID Key Software Administration
Connector ID Key Properties Connector ID Key Software

Recommended Versions
Connector ID Key Software Version Details

This is the most used version for 32/64 bit Windows. Use this for interactive installs and with any software distribution tool

Windows - Standard Version 4.7.0-1 that can handle EXE files.

Version: 4.7.0 Ewvaluation License for up to 5 desktops until Nov 22, 2010 © 2010 Liguidware Labs, Inc

If you are interested in other versions of the Connector ID Key for Linux operating systems or using the
Network or Advanced versions of the CID Key then click on the “Other Versions” link at the bottom of the
page and you will see all the remaining versions.

The local install EXE can be pushed using SMS or any other standard software distribution tool. The command
line to install the Connector ID Key for Windows Standard version is:

Install - connectorID - Key-4_7_0-winSt andard.exe /q [ HUBADDRES®=0rhub
dns-nameo] [ MACHI NEGROU@é&up omeancehd In e[ USERGR-@tdkp=0us er
name o]

The Network Shared install can simply be un-zipped onto a network server in a shared folder. The command
line to start the Network shared Connector ID Key is:

netcid start <onetwork -cid - folder -path 0> [-ha fihub-ip -or-dns-named][ -mg
fimachine - group - named] [-ug Auser - group - nameo]

The command line to stop the Network shared Connector ID Key is:
netcid stop < onetwork -cid - folder - path 0>
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If you need to push out the CID Key using Active Directory Group Policy then you can also download the AD
GPO version of the installer which is an MSI along with the Group Policy template that can be used for
software installation. Detailed instructions for both types of install can be found in the Appendix of this
document.

To confirm that the Connector ID Keys have been successfully installed on the desktops or servers, and that
they are reporting data back to the Stratusphere Hub, login to either the Administration or Stratusphere Fit
product modules on your Stratusphere Hub, and go to Inventory > Machines. The machines with Connector ID
Keys running should automatically show up registered in the inventory list, and you should be able to see their
Last Contact Date updating as they make their regular callbacks to send assessment data to the Hub. If
machines are not showing up properly in the list, review your installation steps, that the machine is connected to
network (for registration) and can reach the Hub (using TCP and UDP on port 5501).

Stratusphere’ Print | Help = Log Out
Machines Users Applications
Machines Page 1 0f 3 < Prev Next »
\.fiew: Individual Machines | Groups
Olveme & |mwe |08 version comecter 0 ropeon
O apdlozks-o1 virtal gq;r\r?csgflg(a?k 1f'z\fir'ldo\-\rs(F{) Server 2003, Standard Edition, waztdid 5 31 ES‘T' 18, 2009 5:52:47 FM JEaSrjl_SD, 2010 1:05:27 PM
[ apdlozks-oz yirtal gﬂécrrvolcsgfégi)k \.fz\findows(R) Server 2003, Standard Edition, wI2tdid 5 51 EE'T_' 18, 2009 10:23:01 PM JEaSr]FSD, 2010 1:04:24 PM
O apolozks-o3 virtual gﬂ;rvulcsgfé(ai)k vz\finduws(R) Server 2003, Standard Edition, Watdi-4 5.3-1 ES_T_ 18, 2009 10:40:35 PM JEaSr]FSEI, 2010 1:08:58 PM
[0 anolozka-04 virtual gﬂ;r\fo[sgfé(ai)k vzvindows(R) Setver 2003, Standard Edition, waztdi-4.5.9-1 EE‘T’ 13, 2009 10:55:33 FM JEaSrjl_BD, 2010 1:02:328 PM
[ anolozka-05 virtLal gﬂ;r\fo[sgfé(ai)k vgindows(R) Sefver 2003, Standard Edition, waztdi-4.5.9-1 EE‘T’ 18, 2009 11:02:03 M JEaSrjl_BD, 2010 1:04:08 PM
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3 Assessment Prep 2: Learn the Basics of Stratusphere

This section provides an introduction to the key elements of the Stratusphere Fit product, the product module
used to review and analyze your assessment data. To log in to the product, open your browser and go to
https://[your-virtual-appliance-ip-address], then select Stratusphere Fit from the Product drop-down, and enter
the default username: ssadmin and password: sspassword.

€ LiquidwareLabs

Log In

Product Stratusphere Fit - Licensed Products:
Domain Local Directory - Stratusphere Fit — Assessment and capacity planning
User name ssadmin Stratusphere UX — Diagnostics and service level assurance

ProfileUnity — Uiser profile migration and management
Password eesesssene

Licensed To: Evaluation License
License Expires: Mov 22, 2010
Desktop Limit: 0 used out of 5
User Limit: 0 used out of 5

@© 2010 Liguidware Labs, Inc.

3.1 Assessment Dashboard

The first thing you will see is the assessment dashboard. This provides an overview of the data collected. See
the screenshot below for notes on the sections and usage.
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Assessment Inventory

| Summary | Inspector Reports WD Fit Profile
Assessment Dashboard Use filters to focus on specific Click the refresh page button [ Generate Summary Fepart l
groups or time periods after chaning filters or widgets
A NS R [ Refresh Page ] [ Clear Filter l
Machine Group: [Type to search . Date Range: & standard O Custom
User Group: [Type to search... [x] | Last 60 Minutes V|
The header shows summary information on
Mumber of machines: 31 Mumber of users: 13 machines, users, resource allocation and
Total CPU Allocated: 111.9 GHz Total Memary allocated: 29.6 GB / Total Disk sllocated: 1,435.8 GB
Peak Avg. CPU Used: 6.9 GHz Peak Avg. Memory Used: 14,2 GB Peak Avg. Disk Used: 470.5 GB
WO Fit A Operating System b | Machine Age (Mos) V|

/\ Low:4 Avg:16 High:107

Select widgets to display at each
position from the widget drop-down

Good, 25

Microsoft .., 11 <&Mos, 11

t 3+, 1
- B

Microzoft .., 11 b ’ Other, 2 E 1 4

Microsoftl,., &

Fair, & EMaoz-27r, 19
Click the Inspect link in a widget to
drill-down to more detailed data
Inspect Inspect Inspect

3.2 Inspector

Click on Assessment > Inspector, and you will find a list of interactive reports and graphs that you can use to
explore the assessment data. Use the drop-down at the top of the page to select the view and then click on the
Go button to generate. You can filter the data using controls at the top of the page, and dynamically sort or
drill-down using controls on the data table. Data can also be exported to PDF, XLS, CSV and other formats.
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Stratusphere’ Print  Help | Log Dut

Assessment Select view and click -
Go button to generate After changing filter
suramary | Inspector | Rep elements, click here

to refresh the page

\Y

Use filters to focus on
specific desktops, users or
applications

lse time and date filters to
focus on specific time
period

Machine Assessment Summary ¥

¥ Last 60 Minutes (Jan 27, 2010 4:12:24 PM E PM EST) | Refresh Page | | ClearFilter |
Machine / Group: [Type to search... [x] Date Range: & Standard O Customn Use export buttan ta
User / Group: [Type to search.. [=] Last B0 Minutas 3 export data to
o document farmats
Application: |Type to search... [x] [ onky wihen User Logged Cn \

Hide Graphs | Export

¥DI Fit Trend
io

5 . .
5 —
3 t lIse page controls to move foreward,

< Click an column backward, ar change the number of

headers to sort data : :
t displayed
by specific columns LS ClspAyer onrage

\ = Good Fair = Poar \

Page 1 of 2 < Prey MNext =

o

Machine Count

Click on the drill-down button
for a rowe to drill-down to mare
detailed inspector views

achine  Uniaue Tmeln poll ZLU® GRY  Memory  Memory gpg  DiskUsed Network  [GLOT Graphics VDI o
Avg.ds) Avg.(%) Avg.(®o) . . Avg. - - Avg.(ms)
[xl apolloXP-06 2 26,47 nfa 9.93 12.96 136.67 35.98 9.39 2,51 - 0.89 35.25 Fair
[¥] delxps7a0 1 79,49 nfa 0.93 1.2 - 26,41 10.23 250,32 0.89 71.68 4,22 Fair
[¥] tntatl-1280 1 99.56 nfa 10,41 9,39 841,33 50,64 - 25.81 11.57 6,37 146,75 Fair
[x] apolloXP-09 2 14.29 nfa 1.1 0.27 99,56 26.48 10.27 2.34 - 2,13 24 Fair
[  apolioxP-04 1 9.38 nfa 0.57 0.1z 128.16 33.6 7.07 2,35 7375 1.33 13.25 Fair
[x] apolloXP-02 2 19.17 nfa 0.42 0.1 130.34 38.34 9.15 3.42 73.4 6.34 13.85 Fair
[ apoloxpos 1 2716 nja 7.6 9.37 107.94 2821 657 238 B o 21.55 Fair
3.3 Reports

Click on Assessment > Reports and you will find the list of previously generated reports on your Hub (if you
have just deployed there may not be any in the list). The full list of available reports can be found by clicking
on the Report Library. In the Report Library, you can select and dynamically run individual reports, and you
can Edit them to set-up schedules. Note that all reports are customizable using the open source BIRT Report
Designer, and you can add custom reports to the library as well (for more information on report customization,
as well as how to query the Hub database directly from Excel or other tools, contact Liquidware Labs support).
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sStratusphere’ print  Help | Lo Out

Assessment

Surnmary Inspector | Reports | WL Fit Profile
Reports (3] Categary: |Assessment v| Fage 1 0f 2 < Prev Mext =
Filter reparts shown by
Strtpate: 012810 | [saiem | time they were run,
E @ click Refresh \-"'IEW To view all the available reports,
End Date: |D”2?-IJ1 0 | i |E33'I Fhd | hutton after changing edit schedules or run individual
Date = rm/ddfyyyy; Time = hhimm, hhimm arm, or hhimm pm reports dynamically, click here
\/ Refresh view
Selected 1: | view Report | [ Delete | [ Unselect Wiew Report Library | [ search |
[] Run Date ¥ Category Report Status  Criteria
¥ |lan 27, 2010 5:00;00 PM EST | A& nent | VDT & srnent Time Chart Period 1/26,/10 12:00 AM to 1/26/10 11:59 P
[ ™ Click on row to select Assessment  Machine Age Complete  Period 1/26/10 4:12 PM to 1/27/10 4:12 P
report to view, then click
[ RV Report button Assessment  Machines with High CPU Usage Complete  Period 1/26/10 12:00 AM to 1/26/10 11:59 PM, Threshold 20
[] 7Jan 27, 2010 2:34:21 PM EST  Assessment  Application Assessmernt Summary Complete  Period 1/26/10 12:00 AM to 1/26/10 11:59 PM
[ Jan 27, 2010 1:45:36 PM EST  Assessment | Assessment Findings Complete  Period 1/25/10 12:00 AM to 1/27/10 12:00 AM
[ Jan 27, 2010 9:33:10 AM EST  Assessment  Assessment Findings Complete  Period 1/26/10 12:00 AM to 1/26/10 1159 PM
[0 Jan 27, 2010 4:00:00 AM EST  Assessment DI Fit By Liser Complete  Period 1,/26/10 12:00 AM to 1/26/10 11:59 PM
[ Jan 27, 2010 <0000 AM EST  Assessment  Pealk Metworlk IO by WDI Fit Level Complete  Period 1/26/10 4:00 &M to 1/27/10 <:00 AM
» Stratusphere’ Print  Help Log Out
Surnmary Inspector | Reports | | change report output
farrmat or schedule
Report LibI'EII'Y Category: | Assessment L~ v—l Page 1 of 3 2 Prew Mext =
»
New | Selected 1: | Search archives | [ Edit | [ Run | [ Delete | [ Unselect Wiew Archives | Manage Categories |[ search
[] cCategory & Report Schedule Archived Criteria
1 Assessment Application Assessment Surnmary Daily at 6:00 PM 47 Last 24 Hours
[ assessment application Usage Details Diaily at 6:30 PM i Last 24 Hours
[ assessment application Usage Surmmary Daily at 6:45 PM fi Last 24 Hours
Diaily at 1;10 AM de Yesterday (prior calendar day), Threshold 10

F] 3 Daily at 1:00 AM 42 Yesterday (prior calendar day), Threshold 150

[] asq Click on row to select a report, ifie} Daily at 1:00 AM 20 esterday (prior calendar day), Threshold 25
then click Run button above to . )

O as launch the report 10 Daily at 1:00 AM 42 Yesterday (prior calendar day), Threshold 25

[0 assezzmer Y] ok oh Memaory Usage Daily at 1:15 AM 41 Yesterday (prior calendar day), Threshold 50000

[0  Aassessment Asszssment Findings 12 Yesterday (prior calendar day)

3.4 Inventory

In the Inventory section of the Stratusphere Fit product, you can view information on the Machines (desktops),
Users and Applications in your environment. Once you have installed your Hub and deployed Connector ID
Keys to the target desktops, the Inventory information will automatically begin populating, and data will be
updated regularly (according to the Callback Frequency defined for the Connector ID Keys as discussed in
previous section above). Select individual items from the Inventory lists and click on the Edit button to view
more details — for example select a Machine and click Edit to view the configuration data gathered from that
machine. The Inventory section is also where you can create and manage groups.
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sStratusphere’ Print | Heln  Log Dut

Inventory

Take actions an Search for
.| Machines | Users Applications soleciod items specific items
Machines ? lManage Groups I Page//ofﬁ < Prev Next >
Mew | Selected 1: | Edit | [ AddToGroup || Delete || Unselect |[Mare actions.. % view: Individual Machines | Groups | |[ search

Connector ID

[] Name 4 Type OS Yersion Key Version Created On Last Contact
O apalozkaol vitua Microsoft (R windows(R) Server 2003, Standard Edition, Service ] Dec 18, 2009 S:52:47 PM Jan 29, 2010 1:55:07 PM
Pack 2 EST EST
[ apollozka02 virtual r;ﬂicrosoft(R) windows(R) Server 2003, Standard Edition, Service waztdid.5.9-1 Dec 18, 2009 10:22:01 FM Jan 29, 2010 1:51:01 PM
ack 2 EST EST
O apalozkana vitua Microsoft(R) Windows(R) Server 2003, Standard Edition, Service waotdid 5,531 Dec 18, 2009 10:40:35 PM Jan 29, 2010 1:51:48 PM
Pack 2 EST EST
» 2010 1:30:12 P
0 ichsoft(R) wWindows(R) Server 2003, Standard Edition, Service waotdid 5,531 EE'T' 18, 2009 11:03:03 PM JEaSr]r29, 2010 1:53:49 Pp
Click on row to select ! ! ! . Dec 18, 2009 2:49:27 P Jan 29, 2010 1:50:52 FM
[ apd itern for Edit b Windows XP Professional, Service Pack 2 wa2tdi-4.5.2-1 EST EsT
[0 apolloxP-02  Wirtual | Microsoft Windows %P Professional, Service Pack 2 waztdi-4.5.2-1 EE.T. 18, 2009 S:4%:27 PM JEaSr]r29, 2010 1:50:10 PM
»Stratusphere’ Print Help = Loq Out
Assessment Inventory
Machines | Users | Applications
Users Page 1 of 4 = Prev Mext =
I e Selected 1: ’ Edit ] ’ &dd To Group ] ’ Delete ] ’ Unzelect HMore actionz... Vhliew: Individual Users | Groups — |tnitga H Search
" | Username ¥ Domain Email Address Role Enabled Created On
[0 tweety testaD tweety@tntga.com User Dec 18, 2009 9:48:33 PM EST
F] torn testaD tom@tntga.com Dec 18, 2009 10:33:37 PM EST
] teresa testah teresaf@tntga.com User es Dec 18, 2009 9:48:33 PM EST
F] tamyra testaD tarmyra@tntga.com Uzer Yes Dec 18, 2009 9:48;323 PM EST
] tabitha testAD tahitha@tntga.com User Yes Dec 18, 2009 9:48:33 PM EST
F] Syhrester testaD Sylvesten@tntga.com Uzer Yes Dec 18, 2009 9:48;323 PM EST
» Stratusphere’ Print | Help = Log Out
Assessment Inventory
Machirnes Lsers | Applications |
Desktop Applications Page 1 a0f 5 x Prev Mext »
Wiew: Desktop applications | Metwork Applications | [ Search
e . Machines Estimated size  Installs  Installs
Application Name L IR Installed On (KB} Services  Device Drivers RIDEEEEES
Acrobat,com 0.0.0 1 1,623
Acrobat.comn 1.1.377 1
Adobe ATR 1.0.4990 1
Adobe AIR 1.0.8 1 24,847
Adobe Flash Player 10 Plugin 10.0.22 1
Adobe Reader 9.1 9.1.0 1 142,333
Application Layer Gateway Service 5.1.2600 4 43 ala.exe
CTF Loader 5.1.2600 1 15 ctfrmon.exe
Client Server Runtime Process 5.00.2195 1 5 Csrss.Exe
Client Server Runtime Process 5.1.2600 7 5] CSr55.8X8
Client Server Runtime Process £.1.7600 1 ] Csrss.Exe
Connector D 4.5.4 10 4,376 Yes fes tntupdsye.exe, tntuidsve, exe, tntord.exe

© 2010 Liquidware Labs Page 24



For more details on the configuration of individual machines, go to Inventory > Machines, select a machine and
click on the Edit button. You can view details about the hardware, OS, installed applications and patches.

@;'gtratusphere" Print  Help | Log Out
| Machines | Users Applications
Machines Page 1 0f 1 < Prev MNext =
New | Selected 1f | Edit | } addTo Group | [ Delete | [ Unselect |[More actions.. % lview: Individual Machines | Groups |[ search |
[] Name Typey  OS Version Eg;";i‘r';fgnm Created On Last Contact

Feb 6, 2010 3:58:27 PM  Feb 8, 2010 10:35:39

Microsoft Windows P Professional, Service

[ xpd5drcs-2 Wirtual Pack = w3ztdi-4.5.4-1 EST AM EST
¢Stratusphere Print Help = Loq Out
L i
Assessment Inventory
| Machines | sers Applications

Edit Machine : frf-pwxp. tntatl intarnal

| Machine Properties | Connector ID Key Properties Installed Applications
05 Microsoft Windows %P Professional, Service Monitors: 1280 % 1024;
Pack 2
Disks: 2 local;
CPU: Intel(R) PentiumiR) 4 CPU 2,40GHz, 1 core;
Printers:

Age: 3234 days
NICs: WIA PCI 10_100Mb Fast Ethernet adapter -

W Directory: Packet Scheduler Miniport, 100 Mhb;
WM Hosted on: Other devices:
Connector 1D Key Version: w3Z2idi-4.5.4-1 Last Contact: Feb 8, 2010 10:31:56 &M EST

Creation Date: Feb 8, 2010 10:09:42 AM EST

¢Stratusphere Print = Help | Loq Out
[
Assessment Inventory

| Machires | Users Applications

Edit Machine : inf-pwxp. tntatl infarnaf

Machine Properties Connector ID Key Properties installed Applications

| [ Search ]
. . Estimated Installs Uses Installs Date
Application ~ HEEEE Size (KB) Services Services Device Drivers PHEEEEEEE Installed
Dec 18,
Acrobat.com 0.0.0 1,623 2008
Acrobat.com 1.1.377
Adohe AR 1084990 24,847 DEE 1,
. ! 2008
Adobe AIR 1.0.4990
Adobe Flash Player 10 Plugin 10.0.22.87
Adobe Reader 9.1 2.1.0 142,333 Apr 15, 2009
Client Server Runtime Process 5.1.2600.2180 & Crss.exe Apr 14, 2008
thtupdsyve. exe, thtuidsye. exe,
Connectar ID 4.5.4.1 4,376 Yes (31 Yes (31 vYes (3) trtgrd.cxe Feh 2, 2010
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3.5 VDI Fit Profile

The VDI Fit Profile is part of Liquidware Labs’ patent-pending VDI Fit rating system, used to continuously rate
desktop and user resource utilization on physical desktops as to how well it will fit on virtual desktops. The
rating system categorizes a desktop or user on eight metrics, each one rated Good, Fair or Poor according to
thresholds defined in the profile. You can specify relative weights for each metric (zero to exclude a metric).
Also, you can identify specific applications that are known to be a poor fit on virtual desktops, then any time the
application is detected in use, Stratusphere will automatically categorize the user and desktop as a poor fit for
virtual desktops.

To view or change the profile settings, login to Stratusphere Fit and navigate to Assessment > VDI Fit Profile.
If you know the target desktop virtualization technologies you will use, you can select them at the top, and click
on the Recommend Profile Settings button to see the recommended profile thresholds for the target
technologies. Note that you can adjust profile ratings after your data collection is complete, and recalculate
VDI Fit for the collected data.

Stratusphere’ Print | Help | Log Out

Assessment Inventory

SUMmMmary Tnspector Renorts WOI Fit Profile

VDI Fit Profile

¥ Desktop Yirtualization Technologies Fecommend Profile Settings
Desktop: Unspecified v Storage Type: Unspecified v
Application/TS: | Unspecified v Provizioning: | Unspecified v
Base 05: | Unspecified v Disk Optimization: | Unspecified N

Machine Resource Fit Indicators

System CPU Load : 20 0 <= |15 <= |90 <= 100 %
Awg, system CPU % Used 2
User CPU Load : 20 0 <= |30 <= |70 <= 100 %
Awg, user CPU % Used 2
Memory Used : 20 0 <= 700,000 | == [1.20000( <= unbounded
Avg. mermory KB Used 2
Graphics Intensity : 20 0 <= |00 <= |EO0 <= unbounded
Avg, nurmber of GDI objects initialized 2
Monitors inUse @ |2 0 <= <= [ <= wunbounded

Humber of displays connected 2

1/0 Resource Fit Indicators

Digk Load : 33 0 <= |15 <= (70 <= unbounded

Avg, disk 10 per second 2
MNetwork Load : 33 0 <= [0 <= (90 <= unbounded

Awg. network KB per second 2
Metwark Latency @ |33 0 <= 180 <= 300 <= unbounded

Avg. network roundirip time {ms) 2

Known Applications With Poor VDI Fit

Application
Add an application

® Do not recalculate YOI Fit for previously saved data
O Recalrulate YOI Fit for data hack to 1

[ Sawve Changes H Cancel ]
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4 Assessment Reports 1: Desktop Configuration and Application Inventory

Once you have completed the data gathering period of your assessment, you are ready to begin generating
reports and analyzing the environment. Analyzing desktop configuration and application inventory data, you
can determine what portion of the population has configurations that will easily fit into VDI, which ones might
have to change, and what applications might be a target for application virtualization as well. This section
provides you information on the key Inspector views and reports from the Report Library that provide you all
the details on desktop, user and application inventory and configuration.

4.1 Desktop Configuration Data

To examine desktop configuration information, navigate to Assessment > Inspector. Select the view Machine
Configuration Charts in the drop-down and generate the charts for the assessment date range. Examine the
configuration data gathered during the assessment, and the distribution of desktops in each category (note that
you can filter data by groups using filters at the top of the page).

Wiew: 05 | CPU | Memory | Monitors | Resolutions | MICs | Printers | Machine A0

Microsoft Windows ¥P Professional, Service Pack 3

Microzoft Windows ¥P Professional, Service Pack 2

Micrasoft{R) Windows(R) Server 2003, Standard Edition, Service Pack 2

Microzoft Windows 7 Professional

Operating System

Microsoft Windows 7 Ultirnate

Microsoft® Windows Vistad Ultimate , Service Pack 2

T

iz iz 24 z0

=]
[

Mumber of Machines

Next go to Assessment > Reports, click on Report Library, and run the following reports for the assessment
time period.

Report Name Description

CPU Models and Speeds Types of CPUs found, number of machines with each type, and associated data

Disk Size and Usage Size of allocated disks, number of machines in each category, associated usage data
External Devices All external devices found on desktops, number of machines with each type of device
Machine Age Ages of desktops, the number of desktops in each age category

Machine Configuration Summary | Complete inventory list of each machine and its high-level configuration data

Memory Size and Usage Size of allocated memory, number of machines in each category, associated usage data
Monitor Resolution Monitor resolutions for the assessed desktops, and the number of desktops with each
Operating Systems Operating Systems detected on the desktops, and the number of desktops with each
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4.2 Application and Document Inventory Data

To view inventory information about all the applications on user desktops, go to Inventory > Applications. You
can search for specific applications by name or process name.

Stratusphere’

Print Help Log Out

aAssessment Inventory

Machirnes Users Applications

Desktop Applications

Application Name

Acrobat.com

Acrobat.com

Adobe AIR

Adobe AIR

Adobe Flash Player 10 Plugin
Adobe Reader 9.1
Application Layer Gateway Service
CTF Loader

Client Server Runtime Process
Client Server Runtime Process
Client Server Runtime Process
Connector 1D

A Version

Machines
Installed On

0.0.0 1
1.1.377 1
1.0.4990 1
1.0.8 1
10.0.22 1
9.1.0 1
2.1.2600 4
5.1.2600 1
5002195 1
5.1.2600 7
6.1.7600 1
4.5.4 10

Wiew: Desktop Applications | Metwork Applications

Estimated size  Installs  Installs
(KB) Services  Device Drivers

1,623

24,647

142,333
43

15

5

&

&

4,376 Yes Yes

Page 1 of 5 = Prew Mext =

Processes
alg.exe
ctfrmon.exe

Carss.exne
Catss.ExNe
Carss.exne
thtupdsye.exe, thtuidsve.exe, thtgrd.exe

To print reports on the application and document inventory data, go to Assessment > Reports, click on Report
Library, and run the following reports for the assessment time period.

Report Name

Description

Application Inventory

Complete inventory of all applications discovered, their details and number of machines

Application Usage Summary

Summary of application usage for each application used on desktops

Application Usage Details

Details of application usage by machine for each application used

Document Inventory Summary

Summary of number of files and sizes found for specified folders and document types

Document Inventory

Details by machine and user on number of files and sizes for specified folders and doc types
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5 Assessment Reports 2: Resource Utilization by Desktop, User and
Application

When the assessment is complete, Stratusphere will have gathered extensive information on the resource
utilization across desktops, which can be viewed and analyzed by desktop, by user, or by application. This
information is critical to understanding what desktops, users and applications can be easily virtualized, and
which ones might not due to extremely high resource requirements. This data is also critical to help with
capacity planning for a target VDI environment. This section covers the Inspector views and the Reports that
you can use to review resource utilization data.

5.1 Desktop Resource Utilization
To examine desktop resource utilization, navigate to Assessment > Inspector. Select the view Resource
Utilization Charts in the drop-down and generate the charts for the assessment date range. Examine the

utilization distributions gathered during the assessment, using filters to zero in on groups or specific times.

Wigwe: CPU | Merniory | Metwiork

S0

40

20

20

io

Number of Machines

i}

<10% 10% 20% 30% 40% S50% 60% FO% S0% 0% 100%

Average CPU Utlization

Also in the Inspector, select the view Machine Assessment Summary from the drop-down list and generate the
report. This shows the summary of utilization data for each machine. You can export the data, and you can
also drill-down to see more granular details for individual machines. Note that machines with the highest
resource utilization are auto-sorted to the top.
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13

Hide Graphs | Export

¥DI Fit Trend

Machine Count

: ) Login
vachs Ui el ooy
[ delxps7z0 1 100 nja
[¥] apoloxp-o7 1 19.06 nja
[ apoloxp-06 2 2062 nfa
[¥] peter-win7pro 1 100 nfa
¥l apolloxp-09 1 1667 nja
¥ apolloxp-os 3 4117 728
[¥] apaloxp-10 1 10.83 nja
[¥] jasomesmith-pc O u] nfa
¥ apolloxp-04 3 4536 nfa

System
CPU
Avg.(%o)

3.13
6.75
10,05
1.74
7.3z
0.83
1.07
2,37
061

 Good Fair lDoorl

Page 1 of 1 « Prev Next =
g;ﬂ Memory  Memory ?Ellil'(ﬁ Disk Used Metwork E;L::]l;l;rip Graphil_:s VDI A
Avg.(%) Avg.{MB)  Avgd®e) ey Avg.(GB) Avg.(KB/s) Avg.(ms) Intensity Fit
1842 [N == [ o> = £8.17 4.25 Fair
g.18 136.92  36.37 10.4 2.39 B - 28.53 Fair
13.7 13273 37.13 1193 2439 EE 1= 34 Fair
5.8 942.37 4195 388 spes  [Goeedl 075 4.2 Fair
958 11078 3081 8.59 2.37 B - 26.11 Fair
0.14 14334 407 9.99 21 5a.8 2.46 29.16 Fair
0.28 B51.08 22.01 7.9 2.3 FEEE 1o 15.14 Fair
2,13 6o5.02 4.4 [fleE) 256 2,84 na 9,74 Good
0.1 14877  39.19 8.31 2.37 42.47 152 330s  [Good

Next go to Assessment > Reports, click on Report Library, and run the following reports for the assessment

time period.

Report Name

Description

VDI Assessment Time Chart

Resource utilization broken down by time, suggest running this for single days

Machines with High CPU Usage

Machines with average % CPU used over a given threshold

Machines with High Disk 10

Machines with average IOPS over a given threshold

Machines with High Memory Usage

Machines with average % Memory used over a given threshold

Machines with High Network 10

Machines with average network kb/s over a given threshold
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5.2 User Resource Utilization

To examine resource utilization by user, go to Assessment > Inspector, select the view User Assessment
Summary from the drop-down list and generate the report. This shows the summary of utilization data for each
user. You can export the data, and you can also drill-down to see more granular details for individual users.
Note that users with the highest resource utilization are auto-sorted to the top.

Hide Graphs | Export

¥DI Fit Trend

User Count

Page 1 of 1 = Prev Next =

User Machines % Time :5';?&::: g;-ls-ltem g;‘;‘_lr Memory Memory II:;:"?:I,(S Disk Used Network E:tl;?]g:”p Graphics ¥DI A
. = s .
Used Active Avals) Avg(%) Avg.(%) Avg.(MB)  Avg.(%0) Avg. Avg.(GB) Avg.(KB/s) Avg.(ms) Intensity Fit

[ david bieneman 1 0 na 261 1639 [CIOEEE 2> |l 203 8.2 £9.91 4.19 Fair
[ derek 4 47.14 nja 1211 1603 13166 on [ 957 s .- 3|22 Fair
[ daisy 1 765 s 2003 2818 21139 5574 1298 2.49 022 0.82 50.60 Fair
® ke 1 s0 i3 1.08 0.18 70.32 18.8 12.09 2.3 475 0.9z 15.2 Fair
F pwu 1 100 nJa 1.81 588 94546 42 2,89 48,65 EEE o 4.2 Fair
[ scottie 2 6665 5 ost 016 1273 =03 [EEEl sse 59,53 134 RN - |
[ sarah 4 41.9 456 0.6 0.1 14419 400e  [EEEE 1000 51.84 135 315 Good
[ ralph 4 4371 @68 071 0.1z 15173 4zie  [EREE 1027 52,44 134 .17 Good

Next go to Assessment > Reports, click on Report Library, and run the following reports for the assessment
time period. As you will see, these reports are designed to leverage defined user groups (recommended for
production environment assessments). For other reports on individual users, see the section on VDI Fit
Analysis below.

Repot Name Description

User Group CPU Utilization (if you have user groups) Shows and ranks groups by CPU utilization
User Group Disk Utilization (if you have user groups) Shows and ranks groups by Disk utilization
User Group Memory Utilization (if you have user groups) Shows and ranks groups by Memory utilization
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5.3 Application Resource Utilization

To examine resource utilization by application, go to Assessment > Inspector, select the view Application
Assessment Summary from the drop-down list and generate the report. This shows the summary of utilization
data for each application. You can export the data, and you can also drill-down to see more granular details for
individual applications. Note that applications with the highest resource utilization are auto-sorted to the top.

Hide Granhs | Export

Application Trends

14k

L

o

g E4k

E

= SR

a

o K

o i i
10:00 AM 11:00 AM 12:00 PM 01:00 PM 02:00 PM 03:00 R
01/29/10 01/29/10 01/29/10 01/29/10 01/29/10 01/29/1
Date
OUTLO Ok, Skype Srmic Sustam = yLC media player-Thinapp = firefox LREETH = mcods swchost " ymware-
rermnoterks
Page 1 of 2 = Prey Mext =
Application T Unique %% Time Load Time Sys.CPU User CPU Total CPU v Memory  Memory 10 Avg. Graphics
Users Running Avg. (s) Avg. (%) Avg. (%) Time Avg. (MB) Avg. (%) (KBfs) Intensity
= %%L”;S'a player- vlc media player.exe S 5477 nja 661 5501 f?h; almin g o 12,79 2056 7396
[ Firefox firefox.exe 2 9857 006 0.11 273 ? hr2min3l qo549 304 208 nfa
[ skyps skype.exs 1 100 n/a 0.17 462 glh; Bmin g e 0.66 491  nfa
¥l symantec cMC Smc s s 4 100 n/a 1.21 0.27 Lhragmin 5 og 0,79 16,46 701
34 =

[x] Symantec CMC SmcGui sMCgul exe 4 100 nfa 051 0,032 51 min 27 5 4,65 0.4 5,452 162
[x] eneric Host Process B vchost exe 15 100 nfa 0.05 0.0z Wmin4s  0.89 2.5 074 412
[¥] Lsa shel lsass. Eme 5 10 nfa 0.48 0.01 24 mirn 40 = 11.19 111 4,95 4
[x] wn WMIPrYSe. exe 5 100 nfa 0.39 0.02 24 rin 18 5 8.82 0.86 531 8.15
[¥] symantec Antivirus rtvscan.exe 5 100 nfa 0.29 0.06 21 min 55 s 16.74 1.18 96,45 5.09

Next go to Assessment > Reports, click on Report Library, and run the following reports for the assessment
time period.

Report Name Description

Application Assessment Summary Summary of application usage and resource requirements for applications
Applications with High CPU Usage Applications with average % CPU used over a given threshold

Applications with High Graphics Intensity Applications with avg. Graphics Intensity (GDI objects) over a given threshold
Applications with High 10 Applications with average 10 kb/s over a given threshold

Applications with High Memory Usage Applications with average % memory used over a given threshold
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6 Assessment Reports 3: Summary Analysis and Recommendations

The final step in using Stratusphere for VDI assessment is to generate the summary analysis and findings
reports. The VDI Fit categorization (Good/Fair/Poor fit for VDI) used in many of the reports is based on the
VDI Fit Profile settings discussed in the prior section above. As part of your assessment analysis, you may
choose to adjust and recalculate VDI Fit according to your target VDI environment. In this section we cover the
key summary reports you can generate and use to construct your final assessment deliverables.

6.1 Application Virtualization Targets
Based on the application inventory and usage data gathered, Stratusphere can help you categorize applications
and identify those which would most benefit from virtualization using technologies such as VMware ThinApp.

You may choose to virtualize applications as a first step towards virtualizing desktops.

Go to Assessment > Reports, click on Report Library, and run the following reports for your time period.

Report Name Description

Application Virtualization Targets Categorizes applications into low/medium/high complexity for app virt

6.2 VDI Fit Analysis

To examine the distribution of desktops or users falling into different categories of VDI Fit (Good/Fair/Poor),
go to Assessment > Inspector, select the view VDI Fit Scatter Plot from the drop-down list and generate the
chart. You can choose to display by Machine or by User. The bar at top shows the distribution, and the scatter
plot shows how the values are clustered on two dimension (CPU/Memory and Disk/Network). You can choose
to display Average fitness ratings, or the Lowest ratings (reflecting peak periods of resource consumption).
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SUrnmmary | Inspector | Reports WD Fit Priofile

DI Fit Scatter Plat v [ Go |

» Yesterday (prior calendar day) (Jan 29, 20100 12:00:00 &M EST) - (Jan 29, 2010 11:59:59 PM EST) | Showing all (nn{ Fefrash Page ] ’ Clear Filter

filter)

Wigny: Machines Average Ratings | Machines Lowest Ratings | Users Sverage Ratings | Users Lowest Ratings

Select wiew

CPU and Memory Fit (Worst - Best)

I0 Fit (Worst - > Best)

Next go to Assessment > Reports, click on Report Library, and run the following reports for your time period.

Report Name Description

VDI Fit by Machine Breaks down assessed machines into Good, Fair, and Poor VDI resource fitness
VDI Fit by User Breaks down assessed users into Good, Fair, and Poor VDI resource fitness

VDI Fit by User Group Shows how users groups are rated for VDI resource fitness Good, Fair, Poor
VDI Assessment Time Chart Shows peak/low usage and VDI Fit by time, suggest run for individual days

VDI Design Baseline Summary of resource usage observed and baseline for VDI capacity planning
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6.3 Assessment Findings Summary

The Assesment Findings report is a single summary Microsoft Powerpoint that includes graphs and data from
many of the reports listed in sections above, all combined into a single report designed for you to customize and
adapt to fit your needs. It includes information on the overall assessment activity, the findings and analysis, and
placeholders for your final recommendations.

To generate the report, login to Stratusphere Fit. On the Assessment dashboard, simply click on the Generate
Summary Report button, then specify the start date and end date of your assessment and click to run. Note that
this report may take 5 minutes or more to run, depending on the length of your assessment and the amount of
data gathered. The final result file will be stored in the Reports archive, where you can access and download
the Powerpoint report.

» Stratusphere’ Print  Help | Log Out
Assessment
| Summary | Inspector Reports WO Fit Profile Click here to generate 1
Aszsessment Findings
Assessment Dashboard Pawerpoint summary | Generate Summary Report |
¥ [ Refresh Page | | Clear Filter ]
Machine Group: [Type to search... (=] Date Range: &) Standard O Custom
User Group: [Type ta search.. =] | Last 60 Minutes b
MNumber of machines: 45 Mumber of users: 14
Total CPU Allocated: 153.8 GHz Total Memary Allocated: 37.6 GB Total Disk allocated: 1,737.8 GB
Peak avg, CPU Used: 6.6 GHz Peak Avg, Memory Used: 17.2 GB Peak Avg. Disk Used: 562 GB
WD Fit hd Operating System hd Machine Age (Mos) V|
Low 4 Avg:12 High: 108
Good, 39
Microsoft .., 26 <&Moz, 27
B
Microsoft .., 9 ‘ E ? ‘ .,_‘ 1
Micrazaft.., & Cther, 4 # T, 1
&Mas-2¥r, 15 -3, 2
Fair, &
» Stratusphere’ Print | Help = Loq Out
Assessment
SUMMary Inspector | Reports | DI Fit Profile
Reports EJ Cateqory: |Assessment V| Page 10f 1 = Prev Mext =
Startats: [01/0100 |8 [roopm |
EndDate: 03010 | [paoew |

Date = rm/ddfyyyy; Time = hhimm, hhimm arm, or hhimm pm

Refresh Yiew

Selected 1 [ View Repaort U} Delets ][ Unselact Wiew Report Library — |&ssessment Findings

[l Run Date ¥ Category Report Status Criteria

[ Search ]

Jan 29, 2010 5:40:02 PM EST Assessment Findings Complete Period 12/1/09 AM to 12/31/09 11:59 PM

[0 Jan 29, 2010 2:55:54 &M EST Assessment Assessment Findings Camplete Period 1/1/10 12:00 AM to 1/29/10 2:55 &AM

=1 Tem M MW AL e AR e P [ oo Pt 4 b e AL AR Lo 4 e a4 e e
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7 Conclusion

In this document we have covered a complete set of steps to evaluate the Stratusphere product for use in VDI
Assessments. You have been introduced to the installation, data gathering, analysis and reporting steps, and
you have seen the advanced features of Stratusphere for assessment data gathering, and VDI analysis and
planning.

For more information on the technical capabilities of Liquidware Labs’ Stratusphere or ProfileUnity Pro, and
for partner or end-user pricing, please visit http://www.liguidwarelabs.com or contact us at:

Liquidware Labs

3600 Mansell Road, Suite 200
Alpharetta, GA 30022

Phone: 678-397-0450

Fax: 678-397-0339

Email: info@liquidwarelabs.com

Liquidware Labs Europe - EMEA
Phone: +41 800 897 114
Email: info@liquidwarelabs.com
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8 Appendix: Deploying Connector ID Keys with AD GPO or SMS

As discussed above, Connector ID Key software is included inside your Stratusphere Hub virtual appliance, and
must be launched on the end-user desktops to gather assessment data. For Windows, there are EXE based
packages that can be installed locally on desktops, and there are also versions that can be installed on a network
server and then launched remotely on the user desktops. The software can be found by logging into the
Administration module of your Stratusphere Hub (at https://[your-hub-ip-address] with default username:
ssadmin password: sspassword), then going to Hub Administration > Connector ID Keys > Connector ID Key
Software.

For evaluation you can manually install the EXE on test desktops, but this section provides further details if you
wish to distribute Connector ID Keys using Active Directory Group Policy or SMS. Local install and remote
launch can all be done silently, without any intrusion for the end users. To remove the software, you can use
the standard procedures to reverse the process described below, or as discussed in sections above you can
simply set any locally installed Connector ID Keys to “dissolve” (auto-delete) themselves after a specified
number of days.

If you have problems or questions regarding the steps described here, please contact
support@liquidwarelabs.com for more information.

8.1 Deploying the Network Connector ID Keys with AD GPO

This section describes how to install the network version and then use Group Policy to automatically launch
Connector ID Keys on desktops. We suggest using Group Policy to launch the Connector ID Key by assigning
Connector ID Key to computers (Computer Group). For those computers, the Connector ID Key will be
launched when the computer starts, and it is available to all users who log on to the computer. A procedure is
also available to completely clean all information off the desktops when assessment is complete.

The steps below describe the installation and launch process.

1. Extract the Network Connector 1D Key
To install the Connector 1D Key, download the Network version and un-zip the files onto a network
share:
1. Create a shared network folder where you will put the Connector ID Key files. (\\file servekshare)

2. Extract the network Connector ID Key files to the share.
3. Set permissions on the share to allow access to the files.
a. Grant either “Authenticated Users” or “Everyone” read permission.

2. To Start Collecting Data:

To start collecting data, create a Group Policy object (GPO) that will launch Network Connector ID:

1. Inthe Group Policy Editor, create a new object and assign netcid.exe as a startup script. This is a
computer or machine policy and should be applied to the OU(s) containing the computers that will
execute Network Connector ID. Please reference the figure below for further assistance.

Script Name: \ \ fileserver \ share \ path \ netcid.exe

Script Parameters: start A\ \ unc\ path \ netcid.exe 0 -ha fhub_ip _or dns 0 [-mg
fimachine_group_name 0O][ -ug Auser_group_name O]

Note: The last two parameters are optional.
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File Action Yiew Help

“F Group Policy Dbject Editor

o NN

_‘:;j’ Mek CID [it-de0t . Lwl.corp] Policy | Name

El @ Cormputer Configuration H] Startup

¢ B[ Software Settings [l shutdawn
B2 windows Settings
]| seripts (StarbupShutdc
H - Security Settings Startup Properties
¢ @] Administrative Templates

B ﬁ User Configuration Seripts I
(L) Software Settings o
-] Windows Settings
-] Administrative Templates

Startup Scripts for Net CID

Mame ‘ Parameters

Edit Script

Script Name:

Scrpt Parameters:

Islall “WileD1\ClientdppstConnectorD -ha 10.5.1.3

I\\fi\em “CligntdppsiConnector D \heteid exe Browse: |

Cancel

Wifile01\Clientéppsinete...  start -ha stratusphere-d.

Show Files,

Up

Do

Agd... |
Edit |
Remove |

licy Object, press

0K | Camcel | ol

3. To Stop Collecting Data:

Once you have completed your data collection and want to stop collecting data and stop the CID Key

process, you should stop network Connector ID.
1. Remove your Start script and create a new Shutdown script. Assign netcid.exe as a shutdown script.

This is a computer policy and should be applied to the OU(s) containing the computers that will have
network Connector ID removed. Please reference the figure below for further assistance.

Script Name: \ \ fileserver

Script Parameters: stop

\ share \ path \ netcid.exe
i\\unc\path\net ci d.

File Action “ew Help

" Group Policy Object Editor

= =N = el

:;j‘ Met CID [it-dc01.Lwl.corp] Policy | Mame

E| Computer Configuration g] Startup

: ([ Software Settings Shutdnwn
E|[:| ‘Windows Settings
i Scripts (Startup/Shutd: Shutdown Properties

H 5 Security Settings
[ Administrative Templates Scripts |
Eﬁ User Configuration
M-[_1 Software Sertings
-] Windows Sattings
-1 Administrative Templates

Shutdown Seripts for Met CID

Mame

| Parameters

WAifile0 yClientdppsinets

Edit Script

Script Name:

I\\filam \ClientappstConnectorl Dhnetcid exe

Script Parameters:

Istop Whfle01 SClientdppshCannectorl D

stop

Browse... |

[Diawr

2

Up

dd

Edit

il

Bemaove

Cancel | Object, press
Show Files...
oK | Cancel | Spply

K Extended , Standard
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8.2 Deploying the Standard Connector ID Keys with AD GPO

This section describes how to use Group Policy to automatically distribute the “locally installed” Connector ID
Keys to desktop machines or users. We suggest using Group Policy to distribute the Connector ID Keys by
assigning Connector ID Key MSI distribution to computers (Computer Group). For those computers, the
Connector ID Key will be installed when the computer starts, and it is configured as a service and is available to
all users who log on to the computer.

Step One: Create a Distribution Point
To assign the Connector ID Key MSI, you must create a distribution point on the publishing server:
1. Create a shared network folder where you will put the Connector ID Key MSI. (\\file servekshare)
2. Copy the Connector ID Key MSI file to the share.
3. Set permissions on the share to allow access to the MSI file.
a. Grant either “Authenticated Users” or “Everyone” read permission.

Step Two: Load Group Policy ADM Template
The ADM Template allows Connector ID options to be specified through Group Policy. Please reference the
figures below for further assistance.

Right Click Administrative Templates under Computer Configuration and select Add/Remove Templates.

':m Consolel - [Console Root'Local Computer Policy',Computer Configuration\,Administrative Templates]

'ﬁn File  Action Wiew Favorites  Window  Help
- | OE B @
(1 cConsole Root

E|_=:j Local Computer Policy

E@ Computer Configurakion
|21 Software Settings

B Administrative Templates

Select an item to view its description. Setting
[Dwindows Components

[L Windows Sektings [dsystem
JeaBs] 2 drniniistrative Templat [CMekwark
& User Configuration AddjRemove Templates... [ZPrinkers
Al Tasks 4
Wigw 4

Mews Window from Here

Mew Taskpad Yiew...

Export List, .,

Help

Select “Add” to load the Liquidware Labs template.

Add/Remove Templates

LCurrent Policy Templates:

Mal

Eifcon ¢ 048

inetres 270 3AE42009 3

system 1704KE 1243042006 3:5..

wmplayer E7KE  4425/200611:1...

wuau 39KB  FAT/200412:4.
Add.. Remove
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Browse to the location the where Liquidware Labs template is located. This template is available from the
Administration section of the Hub. You will need to download it from the hub prior to completing this step.

Policy Templates EHE3

Lok . [5 ADM [ [ = A

File name: ILiquidware Labz. adm j Open I
Files of type: IF'olic:y Templates j Cancel |

7

Once the template has been loaded, close the dialog box.

Add/Remove Templates EE

Cument Policy Templates:

Name | Size | Madified |
conf J9KE 8442004 500 AM
inetres 2T0EKE 34842009 321 PM
Liquidware Labs 1KB  BA320105:17 ...
systam 1704KE 1243042006 3:5...
wmplayer ETKE  4/25/200E11:1...
28] vuiau 39KB  FATA2004 124

Remove | Cloze |

Select View then Filtering

':m Consolel - [Console Root' Local Computer Policy\Computer Configuration’, Administrative Templates'Lig|

n&n Fil=  Action | view Favorites ‘Window  Help
o o ||E Add/Remove Columns, ..

D Console Rook Large Icons
E|_=:j Local Comp Small Icons
-8 compu List
- 50l @ Detail
1w
Caad Filtering...
- {2 System
-] Metwork.
D Printers

@ User Configuration

em ko visw its description, Setting
[ connector 1o

O Cuskamize. ..
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Disable “Only show policy settings that can be fully managed”.

Filtering EHE

:@ Thesze options allow you to filker the Administrative Templates
= palicies.

[ Filter by Requitements information

Select the jtems to be displayed:
At least Internet Explorer 5.0 ﬂ
Atbleast Internet Explarer B Service Pack 1
At least Internet Explorer 6.0 in ‘Windows 2003 Service Pa...
At least Internet Explorer 6.0 in Windows 2003 Service Pa...
Al least Intermet Explorer B.0 in‘Windaws <P Service Pack...

At least Internet Explorer 7.0
L T T T T AR ST A LI
SelectAl | | Desclectl

[ Only show configured policy settings

0_ Only show policy settings that can be fully managedj

Cancel I

Specify Connector ID Options for your environment. Double-click on “Hub Address” and specify the IP

Address or DNS Entry for the Stratusphere™ Hub.

Bﬁ] File Action ‘Wiew Favorites Window Help

'fii Console1 - [Console Root'Local Computer Policy',Computer Configuration', Administrative

= | LHE B @2

[C1 Console Roat Setting
E|_‘§j Local Camputer Palicy M Hub Address
EQ Computer Configuration }a Machine Group
-] Software Settings % User Group

- [ Windows Settings

B[] Administrative Template
D ‘windows Componer
E|D Liquidware Labs
E‘[:I Conneckor ID
] {23 32 Bt
D &4 Bit
[:I System
D Metwark
D Printers

[]---& User Configuration

Step Three: Deploy the Software

Create a Group Policy that deploys the Connector ID MSI package. Please reference the figures below for

further assistance.

Right Click the Software installation option under Computer Configuration and select New then Package.
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"fti Group Policy Object Editor

Fle Action Yiew Help

= AEEDR| @ E

= ConnectorD [it-de0L L corp] Po | ame [ version [ Deployment stats | Sourcs
)-8 Computer Configuration
T g tings There are no items ko shaw in this view,

B[ sofy

(23 wind ings

i [0 Administrative Template

i View 4
=) User Configuration =

[ software Settings Paste:

(23 Windows Settings Refresh

(0 Administrative Template  Eypopt (jst...

Properties

Help

Browse to the location the where the Connector ID MSI is located.
This path should be the UNC path created in Step 1.

Look it I@ ConnectorlD j Q T 2 E-

My Documents

-DCO

LU

File name: Iinstall-connectnrlD-Key-4_B_D-np332.msi j Opel

Files of type: IWlndDws Installer packages [“.msi] j Canc

Select Assigned and then choose OK

Deploy Software HE |

Select deployment method:

" Published
% Azzigned
" Advanced

Select this option ta Azzign the application without modifications.

; Cancel |

Double Click the Connector ID package to open the Properties dialog box.
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"fi Group Policy Object Editor

File  Acktion Wiew Help

e 5 o]

EREYN=c:

&

0
04
Use

04
0
4

g Software installation

_=:_j°ConnectorID[it-chl.LwL.corp]PD Marne  /
= Computer Configuration !

Software Settings

Windows Settings
administrative Templates
r Configuration

Software Settings
Windows Settings
Administrative Templates

Enable “Always wait for the network at computer startup and logon”.

'Hi Group Policy Object Editor

File  Ackion Wew Help

&= &R 2 m

_Efj Cann

eckorID [it-dc01 Lwl.corp] Po

Setting

Skate

E@ Carmputer Configuration
B[] Software Settings
[ Windows Settings

@ Dan't display the Getting Started welcome screen at logon
= Always use classic logon

E

EID Administrative Templates

EI[:I Swstem

([ Windows Components

(] User Profiles

-.[_]] Scripts

-3 Logon

--[_]) Disk Quatas
-2 Met Logon

(7 Group Policy

(] Remote Assistance
(1) Syskem Restare
[ Error Reporting
[ Windows File Prote
—[_] Remote Procedure
-] Windows Time Sers
-] Internet Communic
[+ Distributed COM
7-[_] Metwork

----- D Printers
ser Configuration

@ Run these programs at user lagon
(= Do ot process the run ance list
(= Do not process the legacy run list

wait For the network, at computer startup and logon

Mak configure
Mok configure
Mok configure
Mak configure
Mok configure
Enabled
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8.3 Deploying the Connector ID Keys with SMS

In this example we will use the example folder name \InstallerCache\CID presumed on the SMS host machine
named SMS01. Change these to the actual names in your environment.

Start the SMS Administrative Console and create a new package with the following attributes:
1 Name: Connector ID Keys
1 Version: 4.x.x (specify the actual version to be deployed)
9 Publisher: Liquidware Labs, Inc.
1 This package contains source files: True (checked)
91 Source directory: \SMS01\InstallerCache\CID

Use the default or site specific settings for all remaining attributes.
Create a Distribution Point for this newly created package according to your site needs.

Create a Program specifying the executable installer package:
9 Name: Connector ID Keys
1 Command line:
Install - connectoriD -Key-4 x x-wi nStandard. exe / q [ HUBADL
ip-or-dns-name ¢ MACHI NEGROUP =groum cnhai nmeeo |
[ USERGROUP-groupsmea me 0 ]
Note: The last three parameters HUBADDRESS, MACHINEGROUP, and USERGROUP are optional. The EXE
installer already has information regarding the address of the Stratusphere™ Hub it was downloaded from and has to
register to. However, if you want to override this embedded information, then you must specify the HUBADDRESS

parameter and the installer will ignore the information it has internally. Also, if you want to specify a machine group
and/or user group for automatic registration then you need to specify the last two parameters.

9 Run: Normal

The following is necessary to complete Connector ID Keys installation and registration.
9 Estimated memory: 512 MB RAM or higher
T Maximum allowed run time: 20 minutes
9 Program can run: Whether or not a user is logged on (suggest scheduling install when users are not
logged on)
1 Run mode / Run with Admin rights: True (selected)

You are now ready to create a new Advertisement. Use the following attributes:
1 Package: Connector ID Keys
91 Program: Connector ID Keys Installer
1 Mandatory assignments: Create one or more of these to force the installation of the package without
requiring the user to run advertised programs. Use the default or site specific settings for all remaining
attributes.

Once the advertisement is created, and the scheduled time for deployment arrives, client machines receive the
advertisements and program installation begins. As the installations progress, Stratusphere should display newly
registered machines in Inventory > Machines.
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